Jump to content
TheHotfix.net is closing! Read more... ×
Sign in to follow this  
robinthehood

Halo 2 Mouse Problems

Recommended Posts

When I move my mouse the veiw in the game moves very slowly. I've never seen so much lag time. My system specs are c2d e6600, asus p5n-e sli, 2 gig of kingstin hyperX 6400 ram, 8800gtx, 250gig sata 300 hard drive, and good old win vista. I've tried updating drivers and changing in game video and sound options. I've even tried reinstalling the game. Of course this is a pirated copy of the game but I read where others are running this same torrent with out problems. Does anyone have any ideas? Thanks in advance for any help.

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest yustynn

Did you tweak the mouse sensitivity? If you haven't, then do that. Do it in Halo 2 itself or in the control panel

Share this post


Link to post
Share on other sites

Did you tweak the mouse sensitivity? If you haven't, then do that. Do it in Halo 2 itself or in the control panel

Yes I did try that . I have even tried another mouse. My other games like Quake 4, Fear, HL2 and Advanced Warfighter 2 all play at max settings.

Share this post


Link to post
Share on other sites

Hi everyone. I found the problem. It seems my 8800gtx was the culprit. The card quit working yesterday so I reinstalled my old 7800gt so I could get back up and running. So just for laughs I started playing Halo2 and to my amazement the game played just fine, no mouse lag. My thanks to everyone for your help. Admin, you can close this topic if you like. :thumbsup2:

Share this post


Link to post
Share on other sites

Hi everyone. I found the problem. It seems my 8800gtx was the culprit. The card quit working yesterday so I reinstalled my old 7800gt so I could get back up and running. So just for laughs I started playing Halo2 and to my amazement the game played just fine, no mouse lag. My thanks to everyone for your help. Admin, you can close this topic if you like. :thumbsup2:

The problem was your 880GTX but it's not because the card was faulty or anything. It is because the card was actually TOO powerful for Halo 2.

Very high FPS causes mouse stuttering in the game.

The only reason why your 7800GT appears to fix the problem is because it yields a lower FPS rate.

If you choose to get another 880GTX card you must turn on Vsync via the NVIDIA control panel.

I've included a tutorial here http://forums.haloonwindowsvista.com/forums/thread/2185.aspx

Share this post


Link to post
Share on other sites

If you own a nVidia card, change your "Max Frames Render Ahead" to 3, if 3 doesn't help try 2 and so on until whatever works for you.

http://www.tweakguides.com/NVFORCE_9.html

Theres also a "Max Frames Render Ahead" for ATi but I forgot whats it called.

**NOTE**

The lower the settings is the more the performance will drop but you will be able to use your mouse like before.

Edited by BlackShadow

Share this post


Link to post
Share on other sites

I get horrendous mouse lag with VSYNC turned on. I tried NVTweak in Vista but new options did not appear in the NVIDIA Control Panel :( I also have 8800 and with VSYNC off I get slow mouse/stuttering. No win either way!

Share this post


Link to post
Share on other sites

  I use FPS limiter and Halo 2 now runs without mouse lag. FPS Limiter also helped me with Prototype. It is really bad that they can't properly port over games. I don't know the programs author or homepage, but found it by searching for FPS limiter: FPS_Limiter_0.2.zip

specs:

Windows  7 64bit ultimate

Core 2 Quad Q6700

GeForce GTX 285 driver 257.21

Halo 2 with latest (only?) patch

FPS limiter 0.2

Sorry to bring up an old thread but I have the same problem and this discussion were among the first on a web search, and then we don't have to go through all the arguments and suggestions again.

Share this post


Link to post
Share on other sites

I also had problems with mouse lag in Halo 2 (System Windows 7 ultimate 64 bit, Intel i7 920 Nvidia GTS 250) and I also have a pirated copy of halo. I used the Nvidia Control panel to force vsync on (setting vsyn on in halo is not enough) This fixed the problem.

Share this post


Link to post
Share on other sites

i enabled vsync to keep my fps 60 and now my mouse controls dont stutter

was useing my brothers pc

nvidia gts 250

4gb ddr2 ram 800mhz

500gb hdd

intel core 2 duo 3.6ghz

Share this post


Link to post
Share on other sites

I've found 100% solution for Windows 7 without any vsynch tricks.

1 install Dxtory 2.0.122 (or later)

2 run it, find and set fps limit checkbox

3 switch to HALO 2 and enjoy smothness

PS It's also possible to get rid of FPS indicator (in Dxtory settings)

I hope it helps also on other Windows platforms.

Sorry for my English.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×